Page 1 of 4 123 ... LastLast
Results 1 to 15 of 46

Thread: Showeq 6 and Raspberry Pi 4

  1. #1
    Did you SEQ today? BlueAdept's Avatar
    Join Date
    Dec 2001
    Posts
    1,893

    Showeq 6 and Raspberry Pi 4

    I was successfully able to run SEQ6 on a pi 4 with Raspbian. My pi was a 4gb but it should work on other versions.

    EDIT: SEQ runs on Buster but not newer images. Please install buster and read the edits to get it to work.

    as root or sudo these commands

    apt-get update
    apt-get upgrade
    apt-get install xdm x11-apps libx11-dev libvte9 qt4-default subversion libtool make automake libpcap-dev libxext-dev

    It will ask which window manager you want. Keep lightdm.
    After it is done, reboot.
    --------------------------------------------------------------------------------------------------------
    If you want to use the pi as an access point for your laptop, you will need to install Rasp-ap.

    curl -sL https://install.raspap.com | bash

    https://raspap.com

    reboot and set it up.
    -------------------------------------------------------------------------------------------------------

    ./configure && make && make install

    That is it! It is a lot simpler than the pi 3.

    Edit: added libx11-dev that was not installed. Added it to the list. My default install had libxext-dev already installed, but if configure fails, try installing it.

    Edit2: re-added libxext-dev to the list. I dont know why mine said it was installed already and someone else said it wasnt. It cant hurt, at worst it will say it was already installed.

    New: add libice-dev to the list.
    Last edited by BlueAdept; 06-04-2022 at 11:51 AM.
    Filters for ShowEQ can now be found here. filters-5xx-06-20-05.tar.gz

    ShowEQ file section is here. https://sourceforge.net/project/show...roup_id=10131#

    Famous Quotes:

    Ratt: WTF you talkin' about BA? (Ok.. that sounds like a bad combo of Diffrent Strokes and A-Team)

    Razzle: I showeq my wife

  2. #2
    Administrator
    Join Date
    Oct 2019
    Posts
    377

    Re: Showeq 6 and Raspberry Pi 4

    I'm pretty sure it's not actually failing on the docs (mine are never installed), but rather a silent library check right after the doc check. There are a couple of extra libraries that the configure script is expecting that aren't actually checked for (or otherwise mentioned). I think if you make sure that libxext-dev and libx11-dev are installed, it should configure without disabling qt validation. I've been meaning to tweak the configure scripts to either explicitly check for the presence of those libs, or remove the dependency if it's no longer needed. But unfortunately I haven't had time lately.

  3. #3
    Did you SEQ today? BlueAdept's Avatar
    Join Date
    Dec 2001
    Posts
    1,893

    Re: Showeq 6 and Raspberry Pi 4

    Thanks, Ill try that.

    That worked. It was libx11-dev that it was looking for.
    Last edited by BlueAdept; 01-04-2021 at 08:05 PM.
    Filters for ShowEQ can now be found here. filters-5xx-06-20-05.tar.gz

    ShowEQ file section is here. https://sourceforge.net/project/show...roup_id=10131#

    Famous Quotes:

    Ratt: WTF you talkin' about BA? (Ok.. that sounds like a bad combo of Diffrent Strokes and A-Team)

    Razzle: I showeq my wife

  4. #4
    Administrator
    Join Date
    Oct 2019
    Posts
    377

    Re: Showeq 6 and Raspberry Pi 4

    I've added checks to configure for X11 and Xext, so this will hopefully not be an issue any more.

  5. #5
    Registered User
    Join Date
    Aug 2016
    Posts
    6

    Re: Showeq 6 and Raspberry Pi 4

    Heya,

    First of all great kudos and thanks to the volunteers who keep SEQ running. I've been using it for 19 years, never would have thought the game would have lasted this long, much less SEQ

    I've been running SEQ on a Pi3 for the last 4 years. Big surprise, Qt 4 isn't on my raspian install but that image is also 4+ years old.

    So what image/version of Raspian has Qt4 included with? Or, is there a procedure to apt-get the appropriate packages and get Qt4 going on the old platform? I can install any OS to the Pi you indicate and carry out any commands. Just need to be told what to do

    Many Thanks Guys

  6. #6
    Registered User
    Join Date
    Sep 2020
    Posts
    16

    Re: Showeq 6 and Raspberry Pi 4

    Good stuff. Is there a a way to run the raspberry pi headless, and access it from my windows PC running EQ? Would something like XDMCP be worth looking into?

  7. #7
    Administrator
    Join Date
    Oct 2019
    Posts
    377

    Re: Showeq 6 and Raspberry Pi 4

    Quote Originally Posted by desummon View Post

    So what image/version of Raspian has Qt4 included with? Or, is there a procedure to apt-get the appropriate packages and get Qt4 going on the old platform? I can install any OS to the Pi you indicate and carry out any commands. Just need to be told what to do
    I haven't messed with the pi much, other than a test install on an older one. Hopefully BlueAdept or one of the other pi users can point you in the right direction.


    Quote Originally Posted by Shinigami View Post
    Good stuff. Is there a a way to run the raspberry pi headless, and access it from my windows PC running EQ? Would something like XDMCP be worth looking into?
    I know I've seen posts here about using X forwarding over SSH, and also using Xming. I don't recall anyone discussing XDMCP, but I could have missed it. At any rate, I think it's certainly possible to do what you're asking.

  8. #8
    Registered User
    Join Date
    Sep 2020
    Posts
    16

    Re: Showeq 6 and Raspberry Pi 4

    hmm. I believe I got this installed, but I'm having issues trying to launch it in terminal. When I type showeq in the command line, it says it's an invalid command. I've only used showeq with CentOS thus far, so chances are I am missing something really simple. Do I need to manually add it to PATH or something? Is there a way to directly launch the showeq executable?
    Last edited by Shinigami; 01-23-2021 at 12:19 AM.

  9. #9
    Administrator
    Join Date
    Oct 2019
    Posts
    377

    Re: Showeq 6 and Raspberry Pi 4

    Quote Originally Posted by Shinigami View Post
    hmm. I believe I got this installed, but I'm having issues trying to launch it in terminal. When I type showeq in the command line, it says it's an invalid command. I've only used showeq with CentOS thus far, so chances are I am missing something really simple. Do I need to manually add it to PATH or something? Is there a way to directly launch the showeq executable?
    Running `make install` will default to installing ShowEQ under the /usr/local/ hierarchy, with the executable in /usr/local/bin. This should already be in your path.

  10. #10
    Registered User
    Join Date
    Sep 2020
    Posts
    16

    Re: Showeq 6 and Raspberry Pi 4

    Quote Originally Posted by cn187 View Post
    Running `make install` will default to installing ShowEQ under the /usr/local/ hierarchy, with the executable in /usr/local/bin. This should already be in your path.
    Okay. is the executable just called "showeq" ? or is there an extension

  11. #11
    Administrator
    Join Date
    Oct 2019
    Posts
    377

    Re: Showeq 6 and Raspberry Pi 4

    Quote Originally Posted by Shinigami View Post
    Okay. is the executable just called "showeq" ? or is there an extension
    It's just `showeq`, no extension.

  12. #12
    Registered User
    Join Date
    Jan 2021
    Posts
    12

    Re: Showeq 6 and Raspberry Pi 4

    Which OS are you using? I just ordered PI 4, 8gb should be here tomorrow.
    Any step by step guides anywhere? I search and only saw PI 3.

    FYI, Thanks for your time.

  13. #13
    Registered User
    Join Date
    Dec 2019
    Posts
    36

    Re: Showeq 6 and Raspberry Pi 4

    Quote Originally Posted by BlueAdept View Post

    Edit: added libx11-dev that was not installed. Added it to the list. My default install had libxext-dev already installed, but if configure fails, try installing it.
    Brand new Raspberry pi 4 that I got today from Amazon, after updating and upgrading everything, I needed to install libxext-dev as well as the other packages you noted above. Worked great.

  14. #14
    Registered User
    Join Date
    Jan 2002
    Posts
    5

    Re: Showeq 6 and Raspberry Pi 4

    With a 64-bit install of Raspberry Pi OS from https://downloads.raspberrypi.org/raspios_arm64/ the showeq6 configure script required some help finding the architecture and qt libs.

    I've had success running configure with the following:

    Code:
    ./configure --build=aarch64-unknown-linux-gnu --with-qt-libraries=/usr/lib/aarch64-linux-gnu

  15. #15
    Did you SEQ today? BlueAdept's Avatar
    Join Date
    Dec 2001
    Posts
    1,893

    Re: Showeq 6 and Raspberry Pi 4

    That is overkill. I used a pi4 with 4gb (just what I had on hand. It should work with less since the old worked on Pi3 with 1gb) and it works fine.
    Filters for ShowEQ can now be found here. filters-5xx-06-20-05.tar.gz

    ShowEQ file section is here. https://sourceforge.net/project/show...roup_id=10131#

    Famous Quotes:

    Ratt: WTF you talkin' about BA? (Ok.. that sounds like a bad combo of Diffrent Strokes and A-Team)

    Razzle: I showeq my wife

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

You may post new threads
You may post replies
You may post attachments
You may edit your posts
HTML code is Off
vB code is On
Smilies are On
[IMG] code is On