Results 1 to 3 of 3

Thread: showeq.xml Question

  1. #1
    Administrator
    Join Date
    Sep 2005
    Posts
    334

    showeq.xml Question

    Seeing inconsistent behavior with the terminal MessageTypeFilter defaults and am wondering if my 20 year old showeq.xml preferences are out of whack. Each time I start ShowEQ the terminal MessageTypeFilters have different channels turned on and off and saving prefs doesn't change anything. Relevant xml:
    Code:
        <section name="Terminal">
            <property name="EnabledTypes">
                <uint64 value="7fe8f09dfd68"/>
            </property>
        </section>
    Not sure what to make of that value or how to interpret it. Anyone have thoughts on what may be happening here?

  2. #2
    Administrator
    Join Date
    Oct 2019
    Posts
    306

    Re: showeq.xml Question

    I want to say that value is a bitmask of the message types. 0th bit is on/off for message type 0, 1st bit is on/off for message type 1, etc. The message types are in message.h, I think.

    I've seen some random issues with preferences not saving correctly. I haven't been able to track it down yet, though.

  3. #3
    Registered User
    Join Date
    Aug 2020
    Posts
    47

    Re: showeq.xml Question

    I've been having this same issue, with them flapping between all off and random ones turned on. Been driving me nuts. Saving changes doesn't appear to work.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

You may post new threads
You may post replies
You may post attachments
You may edit your posts
HTML code is Off
vB code is On
Smilies are On
[IMG] code is On