ShowEQ Open Source Project Message Forums FAQ

Here you can find answers to questions about how the board works. Use the links or search box below to find your way around.

Will ShowEQ run on a default install of Mandrake 8.1 or RedHat 7.2?

No. You will need to upgrade your QT package to version 3.0 or later, and your GCC version to 3.0 or later as well. We recommend using RedHat 8 or Mandrake 9 unless you know what you are doing.

I am having problems compiling/running/using ShowEQ, where can I turn for help?

The ShowEQ forums are the best place to find help for ShowEQ. Keep in mind that your question has PROBABLY been asked. Before you post a new thread, take the time to use the search feature. If you fail to do this, someone will insult your thread and it will probably be locked as well. Lots of flames are likely to follow. You will feel bad, hurt and unfairly punished. This is normal and acceptable behavior. It is yet another test of your ability to read and comprehend information presented to you. If you are unable to do this, you need to find another place to hang out, this is not the place for you. We will beat you over the head until you get understand this.

I went where you said to get help, but everyone called me mean names and my problem still exists. Did you know that would happen?

People probably made fun of you and called you mean names because you asked the same question that many others have asked before. Did you use the search feature? Maybe you were unable to find anything related to your problem, so you posted your question as "My ShowEQ is broken, help!?" and this could be the problem. When asking for help, you need to provide as much possible information as you possibly can. This includes pasting the exact error message and maybe even logs of the problem. Most of the people who help on these forums are not psychic or choose not to use their psychic abilities on these types of posts.

For some reason even though I compiled and run ShowEQ, no map is loaded and no mobs or other info is shown. Is ShowEQ broken?

No, chances are pretty good that you are using a switch instead of a hub. To get the information that you are seeing in EverQuest, that data has to be seen by the Linux computer as well. A switch directs traffic only to the two computers (nodes) involved. A hub broadcasts all traffic to all nodes that are connected to it.

If you are connected to the internet with your EverQuest computer using a directly connected dial up, DSL, or cable modem and have another NIC in your computer Microsoft Windows will not broadcast the packets out over the second NIC.

99.9% of the time those Residential Gateway/Routers made by LinkSys, Dlink, etc... with X number of ports are switches. This means you will have to plug all your computers into a real hub, then uplink that hub to your router/gateway.

Another recent "feature" of many current hubs is that in a most situations, they will behave as switches. This sucks, but can be worked around. Typically, the 10mbit and the 100mbit section of a 10/100 hub are switched. So if EQ is 100mbit and SEQ is 10mbit, they won't see each other's traffic. Also, if a 10mbit device is hooked to the 10/100 hub it will frequently become a REAL hub on the 100mbit section. So, if your router is 10mbit and your SEQ and EQ boxes are 100mbit all hooked to the same hub-switch, you should probably be able to sniff packets! This is true for most LinkSys hubs, and some Netgear and Bay Network hubs.

EverQuest was patched today and now ShowEQ isn't working. How long until it is fixed?

Sony often makes changes in the network packet structure on patch days that the ShowEQ development team can't know about, causing it to not work. This is usually resolved within a few hours (sometimes days and once it didn't work for a month or so!), and can be fixed with a cvs update and recompile (see above). Checking the ShowEQ Announcement at the sourceforge forums on patch day will often let you know when the update is complete.

I zoned in, but not all mobs showed up, or the mobs show as unknown. What is wrong?

You must be running a key sniffer for mobs to show up and decode. See question 2.8 for more information. If you are running a key sniffer, and are sure it is set up properly, this could be caused by several things, but the most common is a missed packet between the servers and your EverQuest client. You could have a problem on your network causing your EverQuest computer to ask for retransmits from the servers more often than is considered normal. If ShowEQ doesn't see retransmits, the zone will not be properly decoded. The problem can be caused anything from a bad network card sending erroneous packets over the network, to a low quality hub, to a bad wire or even a bad cable. Try zoning or camping and coming back in. You can also try replacing possible bad hardware (or somehow eliminating it from the list of possible causes).

I am getting an error trying to copy the file /usr/local/share/showeq/showeq.conf.dist, What is wrong?

You are using a slightly old version of the walk-through. This configuration file is no longer used, the new configuration system is XML based and does not require ANY editing.

ShowEQ is working fine, but until it actually decodes I do not see any of the unknown spawns on the map. What is wrong?

The new default for ShowEQ is to NOT show these mobs. To see them, right click on the map and go to the "Show" menu. From there select the "Unknown Spawns" option.

ShowEQ is working fairly well, but the spawn movement is really jerky and seems slow. What is wrong?

The default for ShowEQ is to NOT animate the spawn movement as it is resource intensive. To enable it, right click on the map and go to the "Show" menu. From there select the "Animate Spawns" option.

I don't want to piss anyone off, but I would like to point out that a lot of the developers are pretty mean. What is up with that?

Well, I will try and answer this to the best of my ability based on my opinion and my observations over the past nearly 2 years. Nearly all of the intelligent Linux users who also use ShowEQ start out with the best of intentions. If you go back in time, you would find that both Ratt and Casey were very nice and tried to help everyone they could. Another good example is adenine! who wrote a VERY good install guide for RedHat 7.1 and answered many questions, but has since disappeared off the face of the earth (update: apparantly he just stopped playing EverQuest). They answered the same question over and over and over again. At some point, they snapped and decided that answering the same stupid post time after time after time was a waste of their time. Then they got mean. Right now, pretty much all the helpful people will treat you like shit if you didn't put any effort into finding your own problem.

What are filters, filters.conf and filters_mapname.conf?

Filters allow you to look for certain creatures by many different attributes such as name, race, level and class. You can have zone specific filters using the filters_zonename.conf file or global filters using the filters.conf file.

Where can I find some really great default filters with more rare mobs than you can shake a stick at?

BlueAdept has a web site here with a great set of filters. Be sure to thank him.

How does filtering work? What is Regex?

Filters work by building a string from the information received about mobs (and PC) from the EQ servers. The filters search these strings using regular expressions. You can find the exact description of the string in the file conf/filters.conf.dist off of the directory you downloaded the CVS into.

A regular expression is a way of describing patterns of letters, numbers, spaces, and other symbols. When this pattern is compared to a string, it is said to match if the special symbols in the pattern match the symbols and characters in the string. Think of it as algebra for words.

The most commonly used special symbols are as follows:
[ ] - matches one character inside the brackets
e.g. - [aA] would match either 'a' or 'A' but not 'b'
\w - matches any word character (letters, symbols, numbers, but not spaces)
\s - matches any space character (space or tab)
. - matches ANY character except return

Special symbol modifiers
+ - Matches 1 or more
* - Matches 0 or more
{ } - Matches X number
e.g. - \w+\s would mean at least one letter (or many more) followed by a space

Example Regex for EQ
Name: [gG]riff.*
The exact characters N a m e : {space}
follow by either g or G
followed by exactly r i f f
followed by 0 or more anything
This would match:
Name: griffawn
Name: Griff The Wonder Basher
Name: griff
Name: griffon, a
and many more.
This would NOT match:
Name: Grimfeather Race: griffon
You can learn more about regular expression all over the web, or with 'man perlre'.

When ShowEQ is running, X seems to be using 80%-100% cpu. If I exit ShowEQ the usage drops back to very very low. What is wrong?

This problem is no longer an issue if you run with QT version 3.0.5 or later. Get QT 3.0.5 or later, or load up a distribution that includes it, and rebuild ShowEQ. The issue should go away.

Spawn point prediction is not correct, it doesn't show a timer for all mobs and sometimes it is not accurate. What is wrong?

Since the zones in EverQuest do not just have fixed time and fixed location spawn points, there are some spawn points that ShowEQ cannot predict. As you are in the same zone for an extended period of time, ShowEQ is learning all the spawn points. It watches them over several spawn cycles, then when it notices patterns it can start to predict when something will spawn. If the spawn point or the timer is random, there is no way for ShowEQ to know this. The longer you spend in the zone, the more spawn points ShowEQ will learn.

I just zoned into a zone that I have previously spent a lot of time in, but ShowEQ is not predicting the spawns yet. What is wrong?

You will have to remain in the zone for 2-3 spawns at each point before it can accuratly re-predict when it is going to spawn. It just takes time.

Everything is setup perfectly. I have a hub and a PPPoE DSL modem, but ShowEQ does not work. What is wrong?

PPPoE is what most DSL providers use for their authentication. If you know anything about it, you also know that it modifies packets by encapulating them. This makes PPPoE EverQuest packets totally different from normal looking EverQuest packets. There are two solutions to this:
  • Rewrite SEQ so that it can detect EverQuest packets inside PPPoE packets. If you do this, please submit a patch to CVS.
  • Get a device which translates PPPoE into normal Ethernet. This may sound like a rare device that you have never heard of, but it isn't. It is just a resedential gateway/router like the ones from LinkSys, Dlink or 3com (or who ever else). You can also use a linux computer which is using PPPoE software on the DSL interface and normal ethernet on the internal network. Just be sure to keep that hub too.

The spawnlog.txt file in my /usr/local/share/showeq directory keeps getting bigger. Is it okay to delete this?

Yes, you may delete this if you like. It is a log of all the spawns ShowEQ has seen occur, along with the zone and time. If you would like to help people out, you can use a script found in the filters forum to clean the spawnlog.txt of all player names, pets and a few other things then send it to them. They can then use this to try and find rare mobs that they have not found before.

Search FAQ

Select this option if you would like your search to look in the text of FAQ items as well as their titles.

Select an option here to specify how you would like your search query to be treated. 'Any words' will return the most numerous but possibly least relevant results, while 'Complete phrase' will return only results that contain exactly what you are searching for.